Explore the Trillion-Row Spreadsheet

The Trillion-Row Spreadsheet is a browser-based interface that allows you to visually interact with your data. Explore the Trillion-Row Spreadsheet to learn how to use some of the most common user interface elements.

The 1010data Insights Platform gives you several options for interacting with the system and analyzing your data. However, when you first get started, you are likely going to spend most of your time in the Trillion-Row Spreadsheet (TRS). The TRS is a browser-based interface that works similarly to many spreadsheet applications, such as Microsoft Excel. The interface uses many elements with which you may already be familiar, such as folders, navigation icons, and menus.

Throughout this tutorial, the Sales Item Detail table (pub.demo.retail.item) is used to introduce you to the major elements in the TRS.

To explore the Trillion-Row Spreadsheet:

  1. In your Internet browser address bar, enter https://www2.1010data.com/prime-latest/ and press Enter.
    Your browser displays the 1010data Insights Platform login page.

  2. Enter your Insights Platform Username and Password, then click Login.
    Logging in may take several minutes.
    Note: If you cannot remember your password, you can reset it. Click Forgot your password? and follow the instructions on the Password Reset page.
    Your browser displays the Insights Platform workspace.

    Each time you open a new workspace, the menu bar and Dashboard are displayed on the canvas. The menu allows you to open a TRS window and start exploring ad hoc analysis in the Insights Platform.

  3. From the menu bar, select Tools > Trillion-Row Spreadsheet.
    The Insights Platform displays the TRS window.

    A. Analysis pane
    The analysis pane occupies the left side of the TRS window. This pane is used to perform an analysis on your data.
    B. Results pane
    The results pane is displayed on the right side of the TRS window. This pane displays the results of your analysis in spreadsheet format. In addition, this pane also displays charts created in the Visualize tab.
    C. Tab bar
    The Tab bar contains the options used to perform an analysis and other actions on your data.
    D. Folders and tables
    The folders and tables visible to you are displayed in the Analyze tab in the analysis pane. Within this tab, you can open tables, which are organized in folders.

    A table is the permanent, unchanging version of the data that is saved on the server. When you open a table in the spreadsheet interface and perform an action or query, it becomes a worksheet. A worksheet is a working copy of the table. In worksheets, you can work with and manipulate your data.

    E. Search
    The search field in the Analyze tab allows you to search for tables, folders, and other objects.
    F. Hide/Show
    To hide the analysis pane, click the Hide () icon on the right side of the pane. This is helpful when you need more space to view your data in the results pane. Click the Show () icon to reveal the analysis pane when it is hidden.
  4. In the Analyze tab, locate the Published Data folder and click the Expand () icon to the left.
    The Published Data folder opens, revealing additional folders.
    Note: You can also double-click a folder to open it.
  5. Double-click the Demo folder and then double-click the Retail folder.
    The Retail folder opens, revealing the tables contained in the folder.

    In the image above, the red box outlines the Demo folder and its contents. The Retail folder is open and in it is a table titled Sales Item Detail.

  6. Click the Sales Item Detail table.
    TRS displays the New operation panel in the analysis pane on the left and the Sales Item Detail table in the results pane on the right.

    This is the basic view of a table in TRS. After a table is opened, the Analyze tab displays the analysis timeline. Use the timeline to move backward or forward through the steps of your analysis. The path to the table in which you are currently working is displayed in step 1 of the timeline.
    Note: As you work through the tutorials in this guide, you may need to resize the TRS window to see the full table.

    Next to the Analyze tab are additional tabs which are used to interact with your data. The table below provides a description of each tab and its available options.

    Table 1. Tab menu
    Tabs Tab description
    Analyze In a new TRS window, this tab displays options for opening common Insight Platform items such as tables and queries.

    After a table is open, the Analyze tab displays the analysis timeline which provides quick access to perform operations like summaries, tabulations, and cross tabulations.

    View Use this tab to select from among the various ways to view and interact with the data resulting from your analysis.
    Visualize Options for creating charts based on your data analysis are available from this tab.
    Develop This tab allows you to save your query and provides options to further develop your analysis. For example, you can clone the TRS window and explore different scenarios without losing your original query.
    Export You can save the results of your analysis in a variety of file types, such as CSV and Microsoft Excel, from this tab.
  7. In the heading of the Cost column, click the drop-down arrow () and select Sort Down.
    When you place the cursor on a column header, the sorting drop-down arrow appears.

    TRS sorts the table in descending order based on the Cost column and adds the sort operation to step 2 in the analysis timeline.

    After you perform an operation in either the table or in the timeline, the operation is listed in the timeline.

    At this point, the table becomes a worksheet because an action was performed on the table.

    Note: Sorting is very system-resource intensive. As a best practice, do not sort your table or worksheet until the data is narrowed down to a manageable size. Instead of sorting, first perform a tabulation or select a narrow range of rows.

    Scroll bars, similar to the ones outlined in red in the image above, appear on the right side of the worksheet if the screen cannot accommodate all of the rows and on the bottom of the worksheet if the screen cannot accommodate all of the columns. The scroll bar in the results pane allows you to navigate through the data in your worksheet.

    Note: If a scroll bar is not displayed in your worksheet, all available data is already displayed; no additional rows of data exist.

    For the purposes of this tutorial, a very small data set was created to illustrate the concepts in this topic. In this case, you can scroll through the data in just a few seconds. However, your tables may contain billions of rows. As you work with the TRS, keep in mind that scrolling may not be the most effective way to get to a particular section of data. For that, a better method is to perform a row selection, which is covered in Select rows.

  8. In the Analyze tab, click New operation in step 3 at the bottom of the timeline.

    The New operation step allows you to add an additional operation to the timeline.

    TRS displays the New operation panel.

Now that you have another step in which to perform an operation, you can arrange the columns in the worksheet.

  1. Click Arrange.
    TRS displays the Arrange columns panel.

    The Columns section shows the columns that are currently visible in your worksheet, in the order they are displayed left to right. The Hidden section shows any additional columns contained in your worksheet that are not currently displayed. Using this panel, you can rearrange and hide columns in your worksheet.

  2. Move the Date column so that it is displayed first.
    1. In the Columns section, drag Date so that it is displayed before Transaction ID as shown in the image below.
    2. Click the Submit operation () icon.
    The Date column moves to the first column in the worksheet.

Next, hide the Cost column in the worksheet. While you could do this by performing another arrange operation on a new line, you will instead edit the existing Arrange columns operation in step 3 of the timeline.

  1. Edit the Arrange columns operation to also hide the Cost column.
    1. In the Analyze tab, click the Arrange columns operation in step 3.
      TRS displays the Arrange columns panel.

    2. Drag Cost to the Hidden section.
    3. Click the Submit operation () icon.
    TRS updates the Arrange columns operation and hides the Cost column in the worksheet.

  2. When you are finished with this tutorial, close the TRS window.
Take a little time to familiarize yourself with the basic menus and options in the Trillion-Row Spreadsheet. Make sure you are comfortable opening a table, and do not be afraid to customize the table by rearranging columns so that they are in an order that is useful to you. This will make the next few tutorials much easier, and allow you to focus on the new material presented in them. Before you know it, you will be performing custom analyses on your own data.

For more information about the TRS interface, see Trillion-Row Spreadsheet in the 1010data Insights Platform User's Guide.